Знакомство с формулами поиска данных

Для выполнения поиска значений в таблицах в Excel предоставляется три функции: ПРОСМОТР, ВПР и ГПР. Несмотря на то, что именно эти функции рассматриваются как основные функции поиска информации, они, к большому сожалению, не являются универсальными. Поиск информации поддерживается как обычными средствами Excel, так и другими, более специализированными инструментами поиска данных.

Формула поиска ищет заданное значение и возвращает другое, соответствующее ему значение. Удачным примером в данном случае является обычный телефонный справочник. Если в нем необходимо найти номер телефона человека, вы сначала ищете его имя и фамилию, а затем записываете соответствующий номер телефона.

Примечание

Здесь термин таблица означает прямоугольный диапазон данных, а не табличный объект, созданный с помощью команды ВставкаТаблицыТаблица.

На рисунке выше показан простейший рабочий лист, который содержит несколько формул поиска и таблицу с данными о служащем (диапазон ДанныеСлужащего, начиная с 6-й строки). Если в ячейку C2 ввести интересующую вас фамилию, формулы поиска, введенные в диапазон ячеек D2:G2, найдут в таблице необходимую информацию. В приведенных ниже формулах используется функция поиска ВПР.

D2: =ВПР(C2;ДанныеСлужащего;2;ЛОЖЬ)
E2: =ВПР(C2;ДанныеСлужащего;3;ЛОЖЬ)
F2: =ВПР(C2;ДанныеСлужащего;4;ЛОЖЬ)
G2: =ВПР(C2;ДанныеСлужащего;5;ЛОЖЬ)

В этом примере для извлечения информации из диапазона ДанныеСлужащего используется четыре формулы. Однако, как правило, требуется вернуть только одно значение таблицы, в таких случаях используется только одна формула.

В формулах поиска информации в таблицах данных используются следующие функции.

В начало

Полезное

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *